一、Problem Description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4 Case 2:
7 1 6

二、Solution

贪心问题,计算最大子序列,计算以每个节点为终点的最大子序列,若前一个节点最大子序列和为负则当前节点最大子序列和为其本身,否则当前节点加上前一节点的最大子序列和

三、Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
/**
* date:2017.11.18
* author:孟小德
* function:杭电acm1003
* Max Sum 贪心算法,计算每一个点做为终点的最大子序列和
*/



import java.util.*;

public class acm1003
{
public static void main(String[] args)
{
Scanner input = new Scanner(System.in);

int T = input.nextInt();

for (int i=0;i<T;i++)
{
int N = input.nextInt();

int[] num_N = new int[N];
// 输入数列
for (int j=0;j<N;j++)
{
num_N[j] = input.nextInt();
}

int[][] result = new int[N+1][3];
result[0][0] = num_N[0];
result[0][1] = 1;
result[0][2] = 1;
result[N][0] = num_N[0];
result[N][1] = 1;
result[N][2] = 1;
for (int j=1;j<N;j++)
{
if (result[j-1][0] < 0)
{
result[j][0] = num_N[j];
result[j][1] = j+1;
result[j][2] = j+1;

}
else
{
result[j][0] = result[j-1][0] + num_N[j];
result[j][1] = result[j-1][1];
result[j][2] = j+1;
}
if (result[N][0] <= result[j][0])
{
result[N][0] = result[j][0];
result[N][1] = result[j][1];
result[N][2] = result[j][2];
}
}
System.out.println("Case " + (i+1) + ":");
System.out.println(result[N][0] + " " +result[N][1]
+ " " + result[N][2]);
if (i<T-1)
{
System.out.println();
}
}

}

}

最后更新: 2018年12月27日 19:08

原始链接: https://cwhong.top/2018/12/25/程序日记本/杭电acm1003-Max-Sum/

× Thank you~
打赏二维码