一、Problem Description

上次Gardon的迷宫城堡小希玩了很久(见Problem B),现在她也想设计一个迷宫让Gardon来走。但是她设计迷宫的思路不一样,首先她认为所有的通道都应该是双向连通的,就是说如果有一个通道连通了房间A和B,那么既可以通过它从房间A走到房间B,也可以通过它从房间B走到房间A,为了提高难度,小希希望任意两个房间有且仅有一条路径可以相通(除非走了回头路)。小希现在把她的设计图给你,让你帮忙判断她的设计图是否符合她的设计思路。比如下面的例子,前两个是符合条件的,但是最后一个却有两种方法从5到达8。
image
 
Input
 
输入包含多组数据,每组数据是一个以0 0结尾的整数对列表,表示了一条通道连接的两个房间的编号。房间的编号至少为1,且不超过100000。每两组数据之间有一个空行。
整个文件以两个-1结尾。
 
Output
 
对于输入的每一组数据,输出仅包括一行。如果该迷宫符合小希的思路,那么输出”Yes”,否则输出”No”。
 
Sample Input
 
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 
Sample Output
 
Yes Yes No

二、Solution

这是一个联通问题,即判断图是否联通,使用并查集将各点连接在连接过程中若两点有相同的根结点则不连接解决了回路问题,随后统计所有节点中有多少节点其根结点为其本身,若只有一个则所有节点已联通

三、Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
/**
* date:2017.11.18
* author:孟小德
* function:杭电acm1272
* 小希的迷宫 使用完全的查并集方法
*/



import java.util.*;

public class acm1272
{
public static int[] father = new int[100005];
public static int[] visit = new int[100005];
public static boolean flag = true;

public static void main(String[] args)
{
Scanner input = new Scanner(System.in);

int m,n;
int num;

while (input.hasNextInt())
{
m = input.nextInt();
n = input.nextInt();
if (m == -1 && n == -1)
{
break;
}
if (m == 0 && n == 0)
{
System.out.println("Yes");
continue;
}
//初始化father and visit
for (int i=1;i<100005;i++)
{
father[i] = i;
visit[i] = 0;
}
visit[m] = 1;
visit[n] = 1;
flag = true;
union(m,n);

while (input.hasNextInt())
{
m = input.nextInt();
n = input.nextInt();
if (m == 0&&n == 0)
{
break;
}

visit[m] = 1;
visit[n] = 1;
union(m,n);

}
num = 0;
//若该树是联通的,那么只有一个节点的父节点是其自身
for (int i=1;i<100005;i++)
{
if (visit[i] == 1 && father[i] == i)
{
num++;
}
if (num>1)
{

flag = false;
}
}

if (flag == true)
{
System.out.println("Yes");
}
else
{
System.out.println("No");
}
}

}
public static void union(int m,int n)
{
//合并集合
int a = getParent(m);
int b = getParent(n);

if (a!=b)
{
father[a] = b;
}
else
{
flag = false;
}
}

public static int getParent(int m)
{
//寻找节点的根节点
while (father[m] != m)
{
m = father[m];
}
return m;
}

}

最后更新: 2018年12月27日 19:01

原始链接: https://cwhong.top/2018/12/25/程序日记本/杭电acm1272-小希的迷宫/

× Thank you~
打赏二维码