一、Problem Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
 
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty’s walls were made of wood.
 
One day, Kitty found that there was a crack in the wall. The shape of the crack is
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.
 
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?
 
Input
The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).
 
Output
For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print “impossible” instead.
 
Sample Input
5 3 3 2 1 5 2 2 1
 
Sample Output
2
impossible

二、Solution

贪心问题,一块木板尽量多用几次,最后用的总木块数尽量少,所以先将裂缝安小到大排序

三、Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
/**
* date:2017.11.16
* author:孟小德
* function:杭电acm2124
* Repair the Wall 贪心算法,先最木块进行排序,最大最长的先处理
*/



import java.util.*;

public class acm2124
{
public static void main(String[] args)
{
Scanner input = new Scanner(System.in);

while (input.hasNextInt())
{
int L = input.nextInt();
int N = input.nextInt();

// 输入木块长度
int[] wood = new int[N];
for (int i=0;i<N;i++)
{
wood[i] = input.nextInt();
}

sort(wood);

int len = 0;
int num = 0;
for (int i=0;i<N;i++)
{
if ((len + wood[i]) < L)
{
len += wood[i];
num++;
}
else
{
len += wood[i];
num++;
break;
}

}

if (len >= L)
{
System.out.println(num);
}
else
{
System.out.println("impossible");
}
}
}

// 木块长度由大到小排列
public static void sort(int[] wood)
{
boolean flag = true;
int temp;
for (int i = 0;i<wood.length && flag;i++)
{
flag = false;
for (int j = 0;j<wood.length-i-1;j++)
{
if (wood[j] < wood[j+1])
{
temp = wood[j];
wood[j] = wood[j+1];
wood[j+1] = temp;
flag = true;
}

}
}
}
}

最后更新: 2018年12月27日 18:56

原始链接: https://cwhong.top/2018/12/25/程序日记本/杭电acm2124-Repair-the-Wall/

× Thank you~
打赏二维码